当前位置: 首页 > article >正文

PAT A1032 Sharing

1032 Sharing

分数 25

作者 CHEN, Yue

单位 浙江大学

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

whereAddress is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010

Sample Output 1:

67890

Sample Input 2:

 

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1

Sample Output 2:

-1

 

 * 寻找有相同后缀的第一个字符位置,如果没有相同后缀,则输出-1;
 *
 * 使用静态数组代替链表。
 *
 * 先各自遍历两个链表,将其所有出现元素的下标记录在hs数组中,每出现一次,对应的元素加一,
 * 最后遍历其中一个链表的元素,查看hs数组中的值,如果对应的值等于2,则为答案。

/**
 * 寻找有相同后缀的第一个字符位置,如果没有相同后缀,则输出-1;
 * 
 * 使用静态数组代替链表。
 * 
 * 先各自遍历两个链表,将其所有出现元素的下标记录在hs数组中,每出现一次,对应的元素加一,
 * 最后遍历其中一个链表的元素,查看hs数组中的值,如果对应的值等于2,则为答案。
*/

#include <iostream>

using namespace std;

struct Node
{
    int add, nex;
    char ch;
};

const int N = 1e5+10;
struct Node a[N];
int hs[N];
int h1, h2, n;

void Read()
{
    cin >> h1 >> h2 >> n;
    for(int i=0; i<n; ++i)
    {
        char ch;
        int add, nex;
        
        cin >> add >> ch >> nex;
        a[add] = {add, nex, ch};
    }
}

int main()
{
    Read();
    
    int temp = h1;
    while(temp != -1)
    {
        hs[temp]++;
        temp = a[temp].nex;
    }
    
    temp = h2;
    while(temp != -1)
    {
        hs[temp]++;
        temp = a[temp].nex;
    }
    
    int res = -1;
    while(h1 != -1)
    {
        if(hs[h1] == 2)
        {
            res = h1;
            break;
        }
        
        h1 = a[h1].nex;
    }
    
    if(res != -1)
        printf("%05d\n", res);
    else printf("%d\n", -1);
    
    return 0;
}


http://www.kler.cn/news/18043.html

相关文章:

  • 《基于光学传感器的心房颤动检测:综述》阅读笔记
  • Docker笔记整理
  • 算法 DAY55 动态规划11 392.判断子序列 115.不同的子序列
  • MySQL基础(十一)数据处理之增删改
  • 拨云见日:深入理解 HTML 解析器与有限状态机
  • STC89C51系列单片机与ADC0832通信
  • PingCode 的环境和环境管理
  • 你知道ChatGPT里面的G、P、T分别代表什么吗?
  • 谷歌浏览器 | Chrome DevTools系统学习篇-概述
  • 用 Bitmap 实现亿级海量数据统计
  • 反调试与反反调试
  • 南卡OE系列再添新成员,造型犀利有型,性能强劲动听!
  • Java代码重构学习笔记-在对象之间搬移特性
  • Yolov8改进---注意力机制:ShuffleAttention、ECA、EffectiveSE、SE
  • Canal实战使用(集群部署)和原理解析
  • 代码随想录算法训练营day32 | 贪心算法:122.买卖股票的最佳时机II ,55. 跳跃游戏,45.跳跃游戏II
  • 计算机基础必读书籍
  • 从零开始学习Linux运维,成为IT领域翘楚(二)
  • vue3 - 超详细头像裁剪并上传到服务器,支持按照自定义比例裁切图片效果组件插件(详细示例源码教程,一键复制运行开箱即用)
  • 网络安全——传输层安全协议(3)
  • 深度学习入门篇1
  • Filter过滤器和Listener监听器
  • 【致敬未来的攻城狮计划】— 连续打卡第二十五天:RA2E1的 DTC传输模式
  • 深入浅出堆—C语言版【数据结构】
  • 为什么需要使用Docker
  • 掌握这些GitHub搜索技巧,你的开发效率将翻倍!
  • 使用MindSDK的at-server组件开发从机模组
  • ScriptableObject上的prefab内容暂用,ScriptableObject详解
  • random — 伪随机数生成器(史上总结最全)
  • C++学习day--09 字符串比较、运算符