UFUG2601-OJ palindrome
PS:如果读过题了可以跳过题目描述直接到题解部分
链接:UFUG2601-OJ palindrome
题目
题目描述
Given an integer
x
x
x, returntrue
if
x
x
x is a palindrome, andfalse
otherwise.
输入格式
only one integer number x x x. (Ensure that x x x is within the range of an int.)
输出格式
True
if
x
x
x is a palindrome,False
otherwise
样例 #1
样例输入 #1
121
样例输出 #1
True
样例 #2
样例输入 #2
-121
样例输出 #2
False
样例 #3
样例输入 #3
10
样例输出 #3
False
题解
这道题题目的意思是判断一个数(包括正负号)是否为回文数,直接用字符的格式输入,用函数strlen提取字符长度,首尾比较即可。
需要注意的是,输入字符串时,字符是从0开始存储的。
代码实现
//palindrome
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char x[105];
int l;
int main(){
cin>>x;
l=strlen(x);
int i=0;
while(i<=(l>>1)){
if(x[i]!=x[l-1-i]){
printf("False\n");
return 0;
}
++i;
}
printf("True\n");
return 0;
}