当前位置: 首页 > article >正文

7-16 一元多项式求导(vector)

输入样例:

3 4 -5 2 6 1 -2 0

输出样例:

12 3 -10 1 6 0

代码: 

#include<iostream>
#include<vector>
using namespace std;
vector<int>v1,v2;
int main(){
	int x,y;
	while(scanf("%d%d",&x,&y)!=EOF){
		if(y) v1.push_back(x),v2.push_back(y);
	}
	int temp=v1.size();
	for(int i=0;i<temp-1;i++){
		printf("%d %d ",v1[i]*v2[i],v2[i]-1);
	}
	if(temp>0) printf("%d %d",v1[temp-1]*v2[temp-1],v2[temp-1]-1);
	else printf("0 0");
	return 0;
} 

 


http://www.kler.cn/a/308095.html

相关文章:

  • Spring Cloud Gateway(分发请求)
  • redis7.x源码分析:(1) sds动态字符串
  • 数据挖掘(九)
  • 什么岗位需要学习 OpenGL ES ?说说 3.X 的新特性
  • Redis - 集群(Cluster)
  • sql server 查看io资源使用
  • Linux - iptables防火墙
  • 安全、稳定、高速的跨国文件传输系统
  • Vue3 : ref 与 reactive
  • 【DataSophon】Yarn配置历史服务器JobHistory和Spark集成historyServer
  • 【C++】list常见用法
  • 数据库基础(MySQL)
  • 【C++】——string类的模拟实现
  • 【网络】DNS,域名解析系统
  • Vue Application exit (SharedArrayBuffer is not defined)
  • 数据结构与算法-17高级数据结构_图论(迪杰斯特拉算法)
  • 5分钟熟练上手ES的具体使用
  • Python数据分析-Steam 收入排名前 1500 的游戏
  • 克隆虚拟机,xshell无法传文件,windows无法ping克隆虚拟机,已解决
  • idea2024 Safe Mode解决、配置git出现Can‘t run a Git command in the safe mode、取消受信任项目功能
  • Python | Leetcode Python题解之第409题最长回文串
  • JDBC与MyBatis:数据库访问技术的变迁【后端 15】
  • VScode 怎么缩放界面大小
  • Spring Boot 3项目使用Swagger3教程
  • Web 安全基础教程:从零基础入门到精通
  • chatgpt个人版ssrf漏洞