数论——约数
约数
一个数能够整除另一数,这个数就是另一数的约数。
如2,3,4,6都能整除12,因此2,3,4,6都是12的约数。也叫因数。
1、求一个数的所有约数——试除法
例题:
给定 n 个正整数 ai,对于每个整数 ai,请你按照从小到大的顺序输出它的所有约数。
输入格式
第一行包含整数 n。
接下来 n 行,每行包含一个整数 ai。
输出格式
输出共 n 行,其中第 i 行输出第 i 个整数 ai 的所有约数。
数据范围
1≤n≤100,
2≤ai≤2×1e9
输入样例:
2
6
8
输出样例:
1 2 3 6
1 2 4 8
#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
vector<int> deal(int n)
{
vector<int> p;
for (int i = 1; i <= n / i; i++)
if (n % i == 0)//成为约数的条件
{
p.push_back(i);
if (i != n / i)//边界特判
{
p.push_back(n / i);
}
}
sort(p.begin(),p.end());
return p;
}
int main()
{
int n; cin >> n;
while (n--)
{
int x; cin >> x;
auto y =deal(x);
for (auto a : y)
cout << a << ' ';
}
return 0;
}