当前位置: 首页 > article >正文

A - 123233(atCoder-380刷题笔记)

一、原题描述

Problem Statement

You are given a 66-digit positive integer NN.
Determine whether NN satisfies all of the following conditions.

  • Among the digits of NN, the digit 11 appears exactly once.
  • Among the digits of NN, the digit 22 appears exactly twice.
  • Among the digits of NN, the digit 33 appears exactly three times.

Constraints

  • NN is an integer satisfying 100000≤N≤999999100000≤N≤999999.

Input

The input is given from Standard Input in the following format:

NN

Output

Print Yes if NN satisfies all the conditions described in the problem statement, and No otherwise, in one line.

Sample Input 1

123233

Sample Output 1

Yes

123233123233 satisfies the conditions in the problem statement, so print Yes.


Sample Input 2

123234

Sample Output 2

No

123234123234 does not satisfy the conditions in the problem statement, so print No.


Sample Input 3

323132

Sample Output 3

Yes

Sample Input 4

500000

Sample Output 4

No

二、题目大意

问题陈述

您将获得一个 66 -digit 正整数 NN 。

确定是否 N 满足以下所有条件。

  • 在 的数字 N 中,该数字只 1 出现一次。
  • 在 的数字 N 中,该数字恰 2 好出现两次。
  • 在 的数字 N 中,该数字恰 3 好出现了 3 次。

约束:

N 是一个满足 100000≤N≤999999100000≤N≤999999 的整数。

题目的意思就是问输入的一个6位数之后,看他的1是不是出现一次,2是不是出现二次,3是不是出现三次。换一种想法就是看这个六位数是不是122333。

解法一:那我们的解题思路是不是就可以将输入的数字看成字符串然后对其进行排序,最后看他是不是与“122333”相等。

代码实现如下所示:

#include<bits/stdc++.h>
using namespace std;
string s;
int main() {
  cin >> s;
  sort(s.begin(), s.end());
  if(s == "122333") {
    cout << "Yes";
  }else {
    cout << "No";
  }
  return 0;
}

上述的巧妙之处就是我们将这个输入的数字换成了字符串了。这样我们就可以使用字符串来进行处理了。

解法二:还有一种解法就是你可以一次一次遍历数字然后进行桶计数来解。

代码展示:

#include<iostream>
using namespace std;
typedef long long LL;
LL n, a[10];
int main() {
  cin >> n;
  for(int i = 0; i < 6; i++) {
    a[n % 10]++;
    n /= 10;
  }
  if(a[1] == 1 && a[2] == 2 && a[3] == 3) {
    cout << "Yes";
  } else {
    cout << "No";
  }
  return 0;
}

以上就是我们这380第一题的两种解法了。大家下来可以自己试一下哦~~~


http://www.kler.cn/a/402065.html

相关文章:

  • 【Unity基础】对比Unity中两种粒子系统
  • 使用 Vue 和 Create-Vue 构建工程化前端项目
  • MySQL8 安装教程
  • linux之调度管理(9)-SMP cpu hotplug
  • HarmonyOS Next 关于页面渲染的性能优化方案
  • LeetCode:1. 两数之和
  • WebView2的踩坑记
  • Pr:音频过渡
  • 深度学习的多主机多GPU协同训练
  • 【C++学习(37)】并发性模式:如生产者-消费者、读写锁等。 架构模式:如MVC、MVVM等。属于23 种设计模式吗? RAII 的关系?
  • 传奇996_23——杀怪掉落,自动捡取,捡取动画
  • Ribbon 与 Feign:微服务调用中的差异探究
  • Linux网络——套接字编程
  • 学习记录:js算法(九十五):被围绕的区域
  • 2019年下半年试题二:论软件系统架构评估及其应用
  • Node.js | Yarn下载安装与环境配置
  • 【JAVA】正则表达式中的正向肯定预查
  • Java安全—log4j日志FastJson序列化JNDI注入
  • 创新租赁APP开发提升用户体验与业务效率
  • 【经典】webpack和vite的区别?
  • D - Strange Mirroring(AtCoder Beginner Contest 380)
  • ServletConfig、ServletContext、HttpServletRequest与HttpServletResponse常见API
  • 记录———封装uni-app+vant(u-upload)上传图片组件
  • windows C#-编写 C# LINQ 查询(上)
  • IPv6 NDP 记录
  • vue2侧边导航栏路由