当前位置: 首页 > article >正文

蓝桥杯--最少刷题数--java

问题描述

小蓝老师教的编程课有 N 名学生,编号依次是 1 . . . N。第 i 号学生这学期
刷题的数量是 Ai。
对于每一名学生,请你计算他至少还要再刷多少道题,才能使得全班刷题
比他多的学生数不超过刷题比他少的学生数。
输入格式
第一行包含一个正整数 N。
第二行包含 N 个整数:A1, A2, A3, . . . , AN.
输出格式
输出 N 个整数,依次表示第 1 . . . N 号学生分别至少还要再刷多少道题。
样例输入
5
12 10 15 20 6
样例输出
0 3 0 0 7
评测用例规模与约定
对于 30% 的数据,1 ≤ N ≤ 1000, 0 ≤ Ai ≤ 1000.
对于 100% 的数据,1 ≤ N ≤ 100000, 0 ≤ Ai ≤ 100000.

代码

二分法比中位数快一倍。


import java.io.*;
import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class Main {
    static final BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
    static final PrintWriter print = new PrintWriter(System.out);
    static final StreamTokenizer st = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));

    public static int nextInt() throws IOException {
        st.nextToken();
        return (int) st.nval;
    }


    public static void main(String[] args) throws IOException {
        int n = nextInt();
        int[] a = new int[n];
        int[] count = new int[100001];
        for (int i = 0; i < n; i++) {
            a[i] = nextInt();
            count[a[i]]++;
        }
        for (int i = 1; i <= 100000; ++i) {
            count[i] += count[i - 1];
        }
        for (int i = 0; i < n; ++i) {
            if (count[100000] - count[a[i]] <= count[Math.max(0,a[i]-1)]) {
                print.print(0 + " ");
                continue;
            }
            int l = a[i] + 1, r = 100000;
            while (l < r) {
                int mid = l + r >> 1;
                if (count[100000] - count[mid] <= count[mid - 1] - 1) r = mid;
                else l = mid + 1;
            }
            print.print((r - a[i]) + " ");
        }
        print.flush();
    }


}
import java.io.*;
import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

public class Main {
    static final Scanner sc = new Scanner(System.in);
    static final BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
    static final PrintWriter print = new PrintWriter(System.out);
    static final StreamTokenizer st = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));

    public static int nextInt() throws IOException {
        st.nextToken();
        return (int) st.nval;
    }

    public static void main(String[] args) throws IOException {
        int n = nextInt();
        int[] a = new int[n];
        for (int i = 0; i < n; i++) {
            a[i] = nextInt();
        }
        Integer[] b = new Integer[n];
        int[] ans = new int[n];
        for (int i = 0; i < n; i++)
            b[i] = i;
        Arrays.sort(b, Comparator.comparingInt(o -> a[o]));
        int len = n / 2;
        int c = a[b[len]];
        int l = len, r = len;
        while (l >= 0 && a[b[l]] == c) {
            l--;
        }
        while (r < n && a[b[r]] == c) {
            r++;
        }
        int d = 1;
        if (n - r > l + 1) {
            for (int i = l + 1; i < r; i++) {
                ans[b[i]] = a[b[r]] - a[b[i]];
            }
        }
        if(n-r <= l) {
            d = 0;
        }
        for (int i = 0; i < l + 1; i++) {
            ans[b[i]] = c - a[b[i]] + d;
        }

        print.print(ans[0]);
        for (int i = 1; i < n; i++) {
            print.print(" " + ans[i]);
        }
        print.flush();
    }

}

http://www.kler.cn/a/4866.html

相关文章:

  • django基于Python的智能停车管理系统
  • golang单元测试
  • 9.4 visualStudio 2022 配置 cuda 和 torch (c++)
  • 离线录制激光雷达数据进行建图
  • 【Flutter 问题系列第 76 篇】在 Flutter 中 Builder 组件的作用以及如何解决 Scaffold.of 找不到上下文问题的解决文案
  • 【16】核心易中期刊推荐——机器学习模式识别
  • 班里的一个ACM大佬,居然放弃了某大厂ssp的offer,准备回老家小县城烟草局工作,他是不是傻?...
  • Spring Boot+vue智慧公寓管理系统
  • JDBC教程下篇
  • Blender教程利用Cell Fracture插件制作破碎效果
  • 容器的老祖宗LXC和Docker的关系
  • 第二十五章 绘制简单物体总结
  • Redis Cluster集群搭建、Cluster集群扩缩容、底层原理
  • 参考文献整理 MDPI格式
  • linux查看硬件信息
  • 代码随想录二刷——动规篇章
  • spingboot解析CSV文件
  • 快速搭建python爬虫管理平台
  • Vue计算属性
  • 【华为OD机试 2023最新 】 微服务的集成测试(C++ 100%)
  • 使用ControlNet 控制 Stable Diffusion
  • ACK One GitOps 最佳实践
  • 【算法总结】拓扑排序
  • 初探推荐系统-02