Dijkstra求最短路 I
题目
给定一个n个点m条边的有向图,图中可能存在重边和自环,所有边权均为正值。
请你求出1号点到n号点的最短距离,如果无法从1号点走到n号点,则输出−1。
输入格式:
第一行包含整数n和m。
接下来m行,每行包含三个整数 x,y,z,表示存在一条从点x到点y的有向边,边长为z。
输出格式:
输出一个整数,表示1号点到n号点的最短距离。
如果路径不存在,则输出−1。
数据范围:
1≤n≤500,1≤m≤(10)^5,图中涉及边长均不超过10000。
输入样例:
3 3
1 2 2
2 3 1
1 3 4
输出样例:
3
题解
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 510;
int n, m;
//g[x][y]表示节点x指向节点y的权值,也可表示不存在
int g[N][N];
//dist[n]表示源点到节点n的距离
int dist[N];
//表示state,当值为true时,表示该节点为最优路径,也可理解为标记该节点为最优
bool st[N];
int dijkstra(){
memset(dist, 0x3f, sizeof dist);
dist[1] = 0;
//每次循环都标记一个最优节点路径
for (int i = 0; i < n - 1; i ++ ) {
int t = -1;
//确定该t值为未标记节点中的最短值,即确定一个最优节点路径
for (int j = 1; j <= n; j++){
if (!st[j] && (t == -1 || dist[t] > dist[j])) {
t = j;
}
}
//扩展该t值最优节点的临近节点
for (int j = 1; j <= n; j ++ ) {
dist[j] = min(dist[j], dist[t] + g[t][j]);
}
st[t] = true;
}
if (dist[n] == 0x3f3f3f3f) {
return -1;
}
return dist[n];
}
int main(){
scanf("%d%d", &n, &m);
memset(g, 0x3f, sizeof g);
while (m -- ){
int a, b, c;
scanf("%d%d%d", &a, &b, &c);
//防止重边干扰,只会选择权值最小的
g[a][b] = min(g[a][b], c);
}
printf("%d\n", dijkstra());
return 0;
}