当前位置: 首页 > article >正文

7-12 检查密码

7-12 检查密码

作者 陈越

单位 浙江大学

本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .,还必须既有字母也有数字。

输入格式:

输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。

注意: 题目保证不存在只有小数点的输入。

输出格式:

对每个用户的密码,在一行中输出系统反馈信息,分以下5种:

  • 如果密码合法,输出Your password is wan mei.
  • 如果密码太短,不论合法与否,都输出Your password is tai duan le.
  • 如果密码长度合法,但存在不合法字符,则输出Your password is tai luan le.
  • 如果密码长度合法,但只有字母没有数字,则输出Your password needs shu zi.
  • 如果密码长度合法,但只有数字没有字母,则输出Your password needs zi mu.

输入样例:

5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6

输出样例:

Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

栈限制

8192 KB

代码

#include <bits/stdc++.h>
using namespace std;

bool ifValid(const string &str)
{
    regex pattern1("^[a-zA-Z0-9.]+$");
    regex pattern2("^[a-zA-Z0-9]+$");
    return regex_match(str, pattern1) || regex_match(str, pattern2);
}

bool ifOnlyLetter(const string &str)
{
    regex pattern("^[a-zA-Z.]+$");
    return regex_match(str, pattern);
}

bool ifOnlyNum(const string &str)
{
    regex pattern("^[0-9.]+$");
    return regex_match(str, pattern);
}

string justifyPassword(string password)
{
    if (password.length() < 6)
        return "Your password is tai duan le.";
    else if (!ifValid(password))
        return "Your password is tai luan le.";
    else if (ifOnlyLetter(password))
        return "Your password needs shu zi.";
    else if (ifOnlyNum(password))
        return "Your password needs zi mu.";
    else
        return "Your password is wan mei.";
}

int main()
{
    int N;
    cin >> N;
    getchar();
    while (N--)
    {
        string tempStr;
        getline(cin, tempStr);
        // cout << tempStr.length();
        cout << justifyPassword(tempStr) << endl;
    }
    return 0;
}

优化代码

#include <bits/stdc++.h>
using namespace std;

bool ifValid(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isalnum(c) || c == '.'; });
}

bool ifOnlyLetter(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isalpha(c) || c == '.'; });
}

bool ifOnlyNum(const string &password)
{
    return all_of(password.begin(), password.end(), [](char c)
                  { return isdigit(c) || c == '.'; });
}

string justifyPassword(const string &password)
{
    if (password.length() < 6)
        return "Your password is tai duan le.";
    if (!ifValid(password))
        return "Your password is tai luan le.";
    if (ifOnlyLetter(password))
        return "Your password needs shu zi.";
    if (ifOnlyNum(password))
        return "Your password needs zi mu.";
    return "Your password is wan mei.";
}

int main()
{
    int N;
    cin >> N;
    cin.ignore();
    while (N--)
    {
        string tempStr;
        getline(cin, tempStr);
        cout << justifyPassword(tempStr) << endl;
    }
    return 0;
}
  • 不用复杂的正则表达式判断密码是否合法,而是运用了三个函数isalnum()判断是否为字母或数字,isalpha()判断是否为字母,isdigit()判断是否为数字,加上all_of,对整个字符串进行检查。
  • 使用cin.ignore()而不是getchar()来读取缓冲区的换行符

http://www.kler.cn/a/378883.html

相关文章:

  • 【力扣 + 牛客 | SQL题 | 每日5题】牛客SQL热题216,217,223
  • 【Centos】在 CentOS 9 上使用 Apache 搭建 PHP 8 教程
  • 测长机在测量长度尺寸方面有哪些优势?如何保证测量的准确性?
  • 大数据治理在企业信息化建设中的应用与挑战
  • ELK的ElasticStack语法
  • UE 引入 IOS framework库的坑
  • LeetCode 203. 移除链表元素(java)
  • Android面试整理
  • 【热门主题】000027 React:前端框架的强大力量
  • [C++]:智能指针
  • 大数据之——Window电脑本地配置hadoop系统(100%包避坑!!方便日常测试,不用再去虚拟机那么麻烦)
  • Python画笔案例-095 绘制鼠标画笔
  • [java][基础]HTTPTomcatServlet
  • 高防服务器都有哪些类型?
  • Java 正则基础
  • 生成对抗网络(GAN)如何推动AIGC的发展
  • MacOS如何读取磁盘原始的扇区内容,恢复误删除的数据
  • 【IC每日一题--单bitCDC跨时钟和同步FIFO】
  • [ 应急响应靶场实战 ] VMware 搭建win server 2012应急响应靶机 攻击者获取服务器权限上传恶意病毒 防守方人员应急响应并溯源
  • ssm基于vue搭建的新闻网站+vue
  • Python+Selenium+Pytest+POM自动化测试框架封装
  • 机器学习的模型评估与选择
  • Msys mingw32编译报错 CMake Error: Could not create named generator MSYS Makefiles
  • DIP(Deep Image Prior,深度图像先验)和DMs(Diffusion Models,扩散模型)
  • CytoSPACE·单细胞与空间转录组的高精度对齐
  • API网关 - JWT认证 ; 原理概述与具体实践样例