7-12 检查密码
7-12 检查密码
作者 陈越
单位 浙江大学
本题要求你帮助某网站的用户注册模块写一个密码合法性检查的小功能。该网站要求用户设置的密码必须由不少于6个字符组成,并且只能有英文字母、数字和小数点 .
,还必须既有字母也有数字。
输入格式:
输入第一行给出一个正整数 N(≤ 100),随后 N 行,每行给出一个用户设置的密码,为不超过 80 个字符的非空字符串,以回车结束。
注意: 题目保证不存在只有小数点的输入。
输出格式:
对每个用户的密码,在一行中输出系统反馈信息,分以下5种:
- 如果密码合法,输出
Your password is wan mei.
; - 如果密码太短,不论合法与否,都输出
Your password is tai duan le.
; - 如果密码长度合法,但存在不合法字符,则输出
Your password is tai luan le.
; - 如果密码长度合法,但只有字母没有数字,则输出
Your password needs shu zi.
; - 如果密码长度合法,但只有数字没有字母,则输出
Your password needs zi mu.
。
输入样例:
5
123s
zheshi.wodepw
1234.5678
WanMei23333
pass*word.6
输出样例:
Your password is tai duan le.
Your password needs shu zi.
Your password needs zi mu.
Your password is wan mei.
Your password is tai luan le.
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
栈限制
8192 KB
代码
#include <bits/stdc++.h>
using namespace std;
bool ifValid(const string &str)
{
regex pattern1("^[a-zA-Z0-9.]+$");
regex pattern2("^[a-zA-Z0-9]+$");
return regex_match(str, pattern1) || regex_match(str, pattern2);
}
bool ifOnlyLetter(const string &str)
{
regex pattern("^[a-zA-Z.]+$");
return regex_match(str, pattern);
}
bool ifOnlyNum(const string &str)
{
regex pattern("^[0-9.]+$");
return regex_match(str, pattern);
}
string justifyPassword(string password)
{
if (password.length() < 6)
return "Your password is tai duan le.";
else if (!ifValid(password))
return "Your password is tai luan le.";
else if (ifOnlyLetter(password))
return "Your password needs shu zi.";
else if (ifOnlyNum(password))
return "Your password needs zi mu.";
else
return "Your password is wan mei.";
}
int main()
{
int N;
cin >> N;
getchar();
while (N--)
{
string tempStr;
getline(cin, tempStr);
// cout << tempStr.length();
cout << justifyPassword(tempStr) << endl;
}
return 0;
}
优化代码
#include <bits/stdc++.h>
using namespace std;
bool ifValid(const string &password)
{
return all_of(password.begin(), password.end(), [](char c)
{ return isalnum(c) || c == '.'; });
}
bool ifOnlyLetter(const string &password)
{
return all_of(password.begin(), password.end(), [](char c)
{ return isalpha(c) || c == '.'; });
}
bool ifOnlyNum(const string &password)
{
return all_of(password.begin(), password.end(), [](char c)
{ return isdigit(c) || c == '.'; });
}
string justifyPassword(const string &password)
{
if (password.length() < 6)
return "Your password is tai duan le.";
if (!ifValid(password))
return "Your password is tai luan le.";
if (ifOnlyLetter(password))
return "Your password needs shu zi.";
if (ifOnlyNum(password))
return "Your password needs zi mu.";
return "Your password is wan mei.";
}
int main()
{
int N;
cin >> N;
cin.ignore();
while (N--)
{
string tempStr;
getline(cin, tempStr);
cout << justifyPassword(tempStr) << endl;
}
return 0;
}
- 不用复杂的正则表达式判断密码是否合法,而是运用了三个函数
isalnum()
判断是否为字母或数字,isalpha()
判断是否为字母,isdigit()
判断是否为数字,加上all_of
,对整个字符串进行检查。 - 使用
cin.ignore()
而不是getchar()
来读取缓冲区的换行符