CSP/信奥赛C++刷题训练:经典广搜例题(3):洛谷P1596 :[USACO10OCT] Lake Counting S
CSP/信奥赛C++刷题训练:经典广搜例题(3):洛谷P1596 :[USACO10OCT] Lake Counting S
题面翻译
由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个
N
×
M
(
1
≤
N
≤
100
,
1
≤
M
≤
100
)
N\times M(1\leq N\leq 100, 1\leq M\leq 100)
N×M(1≤N≤100,1≤M≤100) 的网格图表示。每个网格中有水(W
) 或是旱地(.
)。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。
输入第 1 1 1 行:两个空格隔开的整数: N N N 和 M M M。
第
2
2
2 行到第
N
+
1
N+1
N+1 行:每行
M
M
M 个字符,每个字符是 W
或 .
,它们表示网格图中的一排。字符之间没有空格。
输出一行,表示水坑的数量。
题目描述
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John’s field, determine how many ponds he has.
输入格式
Line 1: Two space-separated integers: N and M * Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
输出格式
Line 1: The number of ponds in Farmer John’s field.
样例 #1
样例输入 #1
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.
样例输出 #1
3
提示
OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.
使用广搜解题
#include<bits/stdc++.h>
using namespace std;
//bfs:维护一个队列,以一个点往四周搜索,如果符合条件的话就把它放进队列里
int n,m,ans=0;
char a[110][110];
int dx[8]={-1,-1,-1,0,1,1,1,0};//从左上角,顺时针
int dy[8]={-1,0,1,1,1,0,-1,-1};
int q[10010][2];//模拟队列
void bfs(int x,int y){
int head=1,tail=1;//头、尾指针
q[1][0]=x;//当前点入队
q[1][1]=y;
a[x][y]='.';//当前点标记
while(head<=tail){
for(int i=0;i<=7;i++){//搜索当前队首点的8个方向
int nx=q[head][0]+dx[i];
int ny=q[head][1]+dy[i];
if(nx>=1 && nx<=n && ny>=1 && ny<=m && a[nx][ny]=='W'){
tail++;//队尾下标+1
q[tail][0]=nx;//新点入队
q[tail][1]=ny;
a[nx][ny]='.';//新点标记
}
}
head++;//删除队首元素
}
}
int main(){
cin>>n>>m;
for(int i=1;i<=n;i++){
for(int j=1;j<=m;j++){
cin>>a[i][j];
}
}
for(int i=1;i<=n;i++){
for(int j=1;j<=m;j++){
if(a[i][j]=='W'){
bfs(i,j);
ans++;//答案+1
}
}
}
cout<<ans;
return 0;
}
文末彩蛋:
点击王老师青少年编程主页有更多精彩内容