当前位置: 首页 > article >正文

CSP/信奥赛C++刷题训练:经典广搜例题(3):洛谷P1596 :[USACO10OCT] Lake Counting S

CSP/信奥赛C++刷题训练:经典广搜例题(3):洛谷P1596 :[USACO10OCT] Lake Counting S

在这里插入图片描述

题面翻译

由于近期的降雨,雨水汇集在农民约翰的田地不同的地方。我们用一个 N × M ( 1 ≤ N ≤ 100 , 1 ≤ M ≤ 100 ) N\times M(1\leq N\leq 100, 1\leq M\leq 100) N×M(1N100,1M100) 的网格图表示。每个网格中有水(W) 或是旱地(.)。一个网格与其周围的八个网格相连,而一组相连的网格视为一个水坑。约翰想弄清楚他的田地已经形成了多少水坑。给出约翰田地的示意图,确定当中有多少水坑。

输入第 1 1 1 行:两个空格隔开的整数: N N N M M M

2 2 2 行到第 N + 1 N+1 N+1 行:每行 M M M 个字符,每个字符是 W.,它们表示网格图中的一排。字符之间没有空格。

输出一行,表示水坑的数量。

题目描述

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John’s field, determine how many ponds he has.

输入格式

Line 1: Two space-separated integers: N and M * Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

输出格式

Line 1: The number of ponds in Farmer John’s field.

样例 #1

样例输入 #1

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

样例输出 #1

3

提示

OUTPUT DETAILS: There are three ponds: one in the upper left, one in the lower left, and one along the right side.

使用广搜解题

#include<bits/stdc++.h>
using namespace std;
//bfs:维护一个队列,以一个点往四周搜索,如果符合条件的话就把它放进队列里
int n,m,ans=0;
char a[110][110];
int dx[8]={-1,-1,-1,0,1,1,1,0};//从左上角,顺时针 
int dy[8]={-1,0,1,1,1,0,-1,-1}; 
int q[10010][2];//模拟队列 
void bfs(int x,int y){
	int head=1,tail=1;//头、尾指针
	q[1][0]=x;//当前点入队 
	q[1][1]=y;
	a[x][y]='.';//当前点标记 
	while(head<=tail){
		for(int i=0;i<=7;i++){//搜索当前队首点的8个方向 
			int nx=q[head][0]+dx[i]; 
			int ny=q[head][1]+dy[i];
			if(nx>=1 && nx<=n && ny>=1 && ny<=m && a[nx][ny]=='W'){
				tail++;//队尾下标+1 
				q[tail][0]=nx;//新点入队 
				q[tail][1]=ny; 
				a[nx][ny]='.';//新点标记
			} 
		}
		head++;//删除队首元素 
	} 
}
int main(){
	cin>>n>>m;
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			cin>>a[i][j];
		}
	}
	for(int i=1;i<=n;i++){
		for(int j=1;j<=m;j++){
			if(a[i][j]=='W'){
				bfs(i,j);
				ans++;//答案+1 
			}
		}
	}
	cout<<ans;
	return 0;
} 

文末彩蛋:

点击王老师青少年编程主页有更多精彩内容


http://www.kler.cn/a/383905.html

相关文章:

  • 【JAVA】第3关:素数链
  • JS数据结构之“栈”、“队列”、“链表”
  • C++之queue容器
  • 外包干了2年,快要废了。。。
  • 大数据新视界 -- 大数据大厂之 Impala 性能优化:解锁大数据分析的速度密码(上)(1/30)
  • 轻松实现无网络依赖:手把手教你如何在本地快速部署Llama3模型
  • 【C++】条件变量condition_variable
  • CC协议解读
  • 字节青训每日一题
  • 软考教材重点内容 信息安全工程师 第1章 网络信息安全概述
  • 《TCP/IP网络编程》学习笔记 | Chapter 3:地址族与数据序列
  • 大语言模型(LLM)入门级选手初学教程 III
  • 基于SSM(Spring + Spring MVC + MyBatis)框架的文物管理系统
  • 【WebRTC】视频编码链路中各个类的简单分析——VideoStreamEncoder
  • 【深度学习滑坡制图|论文解读3】基于融合CNN-Transformer网络和深度迁移学习的遥感影像滑坡制图方法
  • C语言 -- qsort的简单使用
  • 【WPF】把一个Window放在左上角/右上角顶格显示
  • c# 深度模型入门
  • 【K8S问题系列 |1 】Kubernetes 中 NodePort 类型的 Service 无法访问【已解决】
  • Docker compose 部署MongoDB
  • Python OpenCV图片读取和保存
  • CSS弹性布局:灵活布局的终极指南
  • 使用Python多线程抓取某图网数据并下载图片
  • Ubuntu 安装 redis
  • 前端基础-html-注册界面
  • 前端Web用户 token 持久化