7-401 平均值
7-401 平均值
分数 10
全屏浏览
切换布局
作者 黄龙军
单位 绍兴文理学院
在一行上输入若干整数,每个整数以一个空格分开,求这些整数的平均值。
输入格式:
首先输入一个正整数T,表示测试数据的组数,然后是T组测试数据。每组测试输入一个字符串(仅包含数字字符和空格,长度不超过80)。
输出格式:
对于每组测试,输出以空格分隔的所有整数的平均值,结果保留一位小数。
输入样例:
1
1 2 3 4 5 6 7 8 9 10
输出样例:
5.5
#include <stdio.h>
#include <stdlib.h>
int main() {
int n;
scanf("%d", &n);
getchar(); // 消耗掉输入缓冲区中的换行符
while (n--) {
char str[81];
fgets(str, 81, stdin);
int n=strlen(str);
int count = 0;
int sum = 0;
for (int i = 0; i<n;) {
int he = 0;
if (str[i] != ' ') {
while (str[i]>='0'&&str[i]<='9'&& i<n) {
he = he * 10 + str[i] - '0';
i++;
}
sum += he;
count++;
} else
while(str[i]==' '&&i<n);
i++;
}
printf("%.1lf\n", 1.0*sum / count);
}
return 0;
}