8641 冒泡排序
SCAU数据结构OJ第六章
文章目录
- 8641 冒泡排序
8641 冒泡排序
Description
用函数实现冒泡排序,并输出每趟排序的结果(要求当一趟冒泡过程中不再有数据交换,则排序结束)
输入格式
第一行:键盘输入待排序关键的个数n
第二行:输入n个待排序关键字,用空格分隔数据
输出格式
每行输出每趟排序结果,数据之间用一个空格分隔
输入样例
10
5 4 8 0 9 3 2 6 7 1
输出样例
4 5 0 8 3 2 6 7 1 9
4 0 5 3 2 6 7 1 8 9
0 4 3 2 5 6 1 7 8 9
0 3 2 4 5 1 6 7 8 9
0 2 3 4 1 5 6 7 8 9
0 2 3 1 4 5 6 7 8 9
0 2 1 3 4 5 6 7 8 9
0 1 2 3 4 5 6 7 8 9
0 1 2 3 4 5 6 7 8 9
代码如下:
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int M=1e5+5;
int a[M],n;
void Print()
{
for(int i=1;i<=n;i++)
{
cout<<a[i]<<" ";
}
cout<<endl;
}
void BubbleSort()
{
int i,j;
for(i=1;i<=n-1;i++)//5 4 8 0 9 3 2 6 7 1
{
bool t=false;
for(j=1;j<n;j++)//4 5 0 8 3 2 6 7 1 9
{
if(a[j]>a[j+1])
{
t=true;
swap(a[j],a[j+1]);
}
}
Print();
if(!t)//如果提前排完序,就不必再进行冒泡,可以提前跳出
{
break;
}
}
}
int main()
{
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>a[i];
}
BubbleSort();
return 0;
}