当前位置: 首页 > article >正文

PAT甲级1053、 Path of Equal Weight

题目

Given a non-empty tree with root R, and with weight Wi​ assigned to each tree node Ti​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<230, the given weight number. The next line contains N positive numbers where Wi​ (<1000) corresponds to the tree node Ti​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1​,A2​,⋯,An​} is said to be greater than sequence {B1​,B2​,⋯,Bm​} if there exists 1≤k<min{n,m} such that A_i=B_i for i=1,⋯,k, and A_k+1​>B_k+1​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

思路

本来没想写的,但是写完这个题快吃饭了,不知道干点什么,就来水一篇吧

思路很简单

先给权重后给子节点,用链表的话需要二次操作才能建树,而且涉及到了ID,放在结构体里面肯定不合适,所以考虑到结构体数组或者说静态树。 

另外说一下,总结点不过100,量级比较小,冗余的话也不要紧

然后另一个要点的话就是DFS或者说回溯算法,都差不多,去遍历这棵树寻找路径

这里的栈有点多余了,用一个vector代替的话应该会更好一点

#include <iostream>
#include <stack>
#include <vector>
#include <algorithm>
using namespace std;
struct node
{
    int weight;
    vector<int> children;
}nodes[105];
vector<vector<int>> paths;
bool cmp(vector<int> a, vector<int> b)
{
    int l = min(a.size(),b.size());
    int i;
    for(i=0;i<l;i++)
    {
        if(a[i] != b[i])
            break;
    }
    return a[i] > b[i];
};
stack<int> path;
vector<int> pathWeight;
int s,weightSum = 0;
void DFS(int cur)
{
    path.push(cur);
    pathWeight.push_back(nodes[cur].weight);
    weightSum += nodes[cur].weight;
    
    if(nodes[cur].children.empty() && weightSum == s) 
            paths.push_back(pathWeight);

    for(int i=0;i<nodes[cur].children.size();i++)
    {
        DFS(nodes[cur].children[i]);
    }
    path.pop();
    pathWeight.pop_back();
    weightSum -= nodes[cur].weight;
    return ;
}

int main()
{
    int n,m;
    cin>>n>>m>>s;
    for(int i=0;i<n;i++)
    {
        cin>>nodes[i].weight;
    }
    for(int i=0;i<m;i++)
    {
        int id,k;
        cin>>id>>k;
        for(int j=0;j<k;j++)
        {
            int Id;
            cin>>Id;
            nodes[id].children.push_back(Id);
        }
    }

    // for(int i=0;i<n;i++)
    // {
    //     cout<<i<<" "<<nodes[i].weight<<" "<<nodes[i].children.size();
    //     for(int j=0;j<nodes[i].children.size();j++)
    //         cout<<" "<<nodes[i].children[j];
    //     cout<<endl;
        
    // }
    DFS(0);
    sort(paths.begin(), paths.end(),cmp);
    for(int i=0;i<paths.size();i++)
    {
        cout<<paths[i][0];
        for(int j=1;j<paths[i].size();j++)
            cout<<" "<<paths[i][j];
        cout<<endl;
    }
}


http://www.kler.cn/a/541006.html

相关文章:

  • PID 算法简介(C语言)
  • 第三个Qt开发实例:利用之前已经开发好的LED驱动在Qt生成的界面中控制LED2的亮和灭
  • ASP.NET Core JWT Version
  • c++ haru生成pdf输出饼图
  • 【kafka实战】06 kafkaTemplate java代码使用示例
  • DeepSeek-r1和O1、O3mini谁更强?
  • 游戏引擎学习第97天
  • 【探索未来科技】2025年国际学术会议前瞻
  • 2025影视泛目录站群程序设计_源码二次开发新版本无缓存刷新不变实现原理
  • 前端基础内容(一)
  • 拉格朗日插值法的matlab实现
  • .net处理dynamic类型运行之后的数据
  • 12.10 LLM 操作能力的边界突破(WebGPT vs SayCan)
  • 数据中心网络架构 — 云网一体化数据中心网络 — 算力网络 — SDN 架构
  • Redis7.0八种数据结构底层原理
  • 区块链100问之加密算法
  • 【机器学习】K-Nearest Neighbor KNN算法原理简介及要点
  • echarts 鼠标移入柱状图展示手指,移入label 展示箭头
  • 美创科技获评“浙江省重点专精特新中小企业”
  • win10 llamafactory模型微调相关②
  • STL函数算法笔记
  • 【扫描件PDF】如何批量识别扫描件PDF多个区域内容保存到Excel表格,基于WPF和腾讯OCR的详细解决方案
  • 【PGCCC】commit_delay 对性能的提升:PostgreSQL 基准测试
  • 25自动化考研复试面试常见核心问题真题汇总,自动化考研复试面试有哪些经典问题?自动化考研复试难不难啊?
  • 如何在 React 中使用 CSS Modules?
  • 给milvus添加账号密码