每日一练2023.12.7—— 情人节【PTA】
题目链接:L1-035 情人节
题目要求:
以上是朋友圈中一奇葩贴:“2月14情人节了,我决定造福大家。第2个赞和第14个赞的,我介绍你俩认识…………咱三吃饭…你俩请…”。现给出此贴下点赞的朋友名单,请你找出那两位要请客的倒霉蛋。
输入格式:
输入按照点赞的先后顺序给出不知道多少个点赞的人名,每个人名占一行,为不超过10个英文字母的非空单词,以回车结束。一个英文句点.
标志输入的结束,这个符号不算在点赞名单里。
输出格式:
根据点赞情况在一行中输出结论:若存在第2个人A和第14个人B,则输出“A and B are inviting you to dinner...”;若只有A没有B,则输出“A is the only one for you...”;若连A都没有,则输出“Momo... No one is for you ...”。
输入样例1:
GaoXZh
Magi
Einst
Quark
LaoLao
FatMouse
ZhaShen
fantacy
latesum
SenSen
QuanQuan
whatever
whenever
Potaty
hahaha
.
输出样例1:
Magi and Potaty are inviting you to dinner...
输入样例2:
LaoLao
FatMouse
whoever
.
输出样例2:
FatMouse is the only one for you...
输入样例3:
LaoLao
.
输出样例3:
Momo... No one is for you ...
思路:
1.用while将名字一个个输入名字
2.判断是否是第2个,如果是则放到数组里,并且标记出来
3.判断是否是第14个,如果是则放到数组里,并且标记出来
4.根据标记的值按要求输出
代码:
#include<bits/stdc++.h>
using namespace std;
int main()
{
string s[100],x[100];
int i = 1;
int t1 = 0,t2 = 0;
while(cin >> s[i])
{
if(s[i] == ".")
break;
if(i == 2)
{
x[0] = s[i];
t1 = 1;
}
if(i == 14)
{
x[1] = s[i];
t2 = 1;
}
i ++;
}
if(t2)
cout << x[0] << " and "<< x[1] << " are inviting you to dinner..." << endl;
else if(t1)
cout << x[0] << " is the only one for you..." << endl;
else
cout << "Momo... No one is for you ..." << endl;
return 0;
}