当前位置: 首页 > article >正文

数据结构,问题 A: 翻转字符串

题目描述

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them. 

Ignatius 喜欢用相反的方式写字。给定 Ignatius 编写的单行文本,您应该反转所有单词,然后输出它们。 

输入 

输入包含多个测试用例。输入的第一行是一个整数 T,它是测试用例的数量。T 测试用例紧随其后。 每个测试用例都包含一行和多个单词。一行最多有 1000 个字符。 输出

 对于每个测试用例,您应该输出经过处理的文本。

输入

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains a single line with several words. There will be at most 1000 characters in a line.

输出

For each test case, you should output the text which is processed.

样例输入 复制
3
olleh !dlrow
m'I morf .udh
I ekil .mca
样例输出 复制
hello world!
I'm from hdu.
I like acm.
提示

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

#include<bits/stdc++.h>
using namespace std;
 
stack<char> q;
 
void print(){
    while(!q.empty()){
        cout << q.top();
        q.pop();
    }
}
 
int main(){
    int n;cin >> n;
    cin.ignore();
    while(n > 0){
        string s;
        getline(cin, s);
        for(char c : s){
            if(c == ' '){
                print();
                cout << ' ';
            }else {
                q.push(c);
            }
        }
        print();
        cout << '\n';
        n --;
    }
    return 0;
}

 


http://www.kler.cn/a/373654.html

相关文章:

  • Linux 文件内容显示
  • 如何从CSV、JSON等格式创建DataFrame
  • Android.mk 写法
  • 《文心一言插件设计与开发》赛题三等奖方案 | NoteTable
  • el-dialog支持全局拖拽功能
  • 【p2p、分布式,区块链笔记 分布式容错算法】: 拜占庭将军问题+实用拜占庭容错算法PBFT
  • 野火鲁班猫4 (RK3588)系统配置
  • Mybatis 统计sql运行时间
  • 嵌入式linux跨平台基于mongoose的TCP C++类的源码
  • 如何在macOS开发中给 PKG 签名和公证(productsign+notarytool)
  • Vue中path和component属性
  • JAVA基础练习题
  • 攻防世界 MISC miao~详解
  • 无人机测绘遥感技术算法概述!
  • Q-learning原理及代码实现
  • 初识 BPF:从 Hello World 开始的内核编程之旅
  • SpringBoot技术:闲一品交易的未来
  • 标准数字隔离器主要特性和应用---腾恩科技
  • CAN报文:位定时和位同步
  • CSS 复习
  • ARM base instruction -- adc
  • 基于LORA的一主多从监测系统_4G模块上巴法云
  • 哈希函数简介
  • 全局数据在Python包中模块间管理方法探讨
  • 红警之家进不去
  • Ribbon的轮询策略实现方法