当前位置: 首页 > article >正文

PAT A1024 Palindromic Number

1024 Palindromic Number

分数 25

作者 CHEN, Yue

单位 浙江大学

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

 n用字符串输入,将字符串转换为vector进行处理,用vector实现两个大整数的加法,最后
 * 再写一个判断回文子串的函数,这就完结了。

/** n用字符串输入,将字符串转换为vector进行处理,用vector实现两个大整数的加法,最后
 * 再写一个判断回文子串的函数,这就完结了。
*/

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

vector<int> Add(vector<int> A)
{
    vector<int> B = A;
    reverse(B.begin(), B.end());
    
    vector<int> C;
    int r = 0;
    for(int i=0; i<A.size(); ++i)
    {
        r += A[i] + B[i];
        C.push_back(r % 10);
        r /= 10;
    }
    
    if(r)
        C.push_back(r);
    
    return C;
}

bool is_level(vector<int> A)
{
    bool flag = true;
    int len = A.size();
    
    for(int i=0; i<len/2; ++i)
        if(A[i] != A[len-1-i])
            flag = false;
            
    return flag;
}

int main()
{
    string s;
    int t;
    
    cin >> s >> t;
    
    vector<int> A;
    for(int i=s.size()-1; i>=0; --i)
        A.push_back(s[i] - '0');
    
    int cnt = 0;
    while(cnt < t)
    {
        if(is_level(A))
            break;
        else
        {
            A = Add(A);
            ++cnt;
        }
    }
    
    for(int i=A.size()-1; i>=0; --i)
        cout << A[i];
    cout << endl << cnt << endl;
    
    return 0;
}


http://www.kler.cn/news/17354.html

相关文章:

  • Java对象的创建方式以及对象的引用
  • 【Elsevier】中科院2区TOP, 高被引119篇, 稳定检索22年, 1周可见刊,5月15截稿~
  • Simulink 自动代码生成电机控制:弱磁控制从仿真到硬件开发板验证实验
  • 豪取BAT!超详细暑期实习算法面经(非科班无论文)
  • 如何监控一个程序的运行情况,然后视情况将进程杀死并重启
  • redis使用总结
  • 对传递函数的零极点、频率响应、稳定性的理解
  • Vue3 如何全局使用按钮截流指令
  • 复古决战快速施法穿墙秒怪分析流程及安全防护
  • 网络基础设施 拥塞控制
  • 基于JavaWeb实现的寻码网文章资讯管理系统
  • 动态页面配置
  • 我有一个方法判断你有没有编程天赋
  • ElasticSearch学习随笔之分词算法
  • 第17章 信息系统安全管理
  • IAST工具是如何工作的?主动和被动IAST有什么区别?
  • 信号完整性分析基础知识之传输线和反射(三):仿真和测试反射波形
  • 开放式基金净值估算数据 API 数据接口
  • 编写服务器重启的脚本(rc.local调用版本)
  • 基于GWO灰狼优化算法的城市路径优化问题GWO-TSP(MATLAB程序)
  • 操作系统——线程调度
  • SpringBoot整合Mybatis-Plus、Jwt实现登录token设置
  • Java回收垃圾的基本过程与常用算法
  • 面试总结,4年经验
  • python语法入门到面向过程编程(二)
  • 类与对象之构造函数
  • SPSS如何进行基本统计分析之案例实训?
  • 什么是工业互联网?5G到底能在工业互联网中承担哪些重任呢?
  • Java实现添加文字水印、图片水印功能
  • java基础知识——27.动态代理