PAT A1024 Palindromic Number
1024 Palindromic Number
分数 25
作者 CHEN, Yue
单位 浙江大学
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.
Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤1010) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.
Output Specification:
For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.
Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3
n用字符串输入,将字符串转换为vector进行处理,用vector实现两个大整数的加法,最后
* 再写一个判断回文子串的函数,这就完结了。
/** n用字符串输入,将字符串转换为vector进行处理,用vector实现两个大整数的加法,最后
* 再写一个判断回文子串的函数,这就完结了。
*/
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
vector<int> Add(vector<int> A)
{
vector<int> B = A;
reverse(B.begin(), B.end());
vector<int> C;
int r = 0;
for(int i=0; i<A.size(); ++i)
{
r += A[i] + B[i];
C.push_back(r % 10);
r /= 10;
}
if(r)
C.push_back(r);
return C;
}
bool is_level(vector<int> A)
{
bool flag = true;
int len = A.size();
for(int i=0; i<len/2; ++i)
if(A[i] != A[len-1-i])
flag = false;
return flag;
}
int main()
{
string s;
int t;
cin >> s >> t;
vector<int> A;
for(int i=s.size()-1; i>=0; --i)
A.push_back(s[i] - '0');
int cnt = 0;
while(cnt < t)
{
if(is_level(A))
break;
else
{
A = Add(A);
++cnt;
}
}
for(int i=A.size()-1; i>=0; --i)
cout << A[i];
cout << endl << cnt << endl;
return 0;
}